首页
社区
课程
招聘
[旧帖] [原创]一个定式思维带来的错误 0.00雪花
2010-12-16 15:36 875

[旧帖] [原创]一个定式思维带来的错误 0.00雪花

2010-12-16 15:36
875
新手可以看吧,老鸟直接可以无视我,丝毫没有技术含量。
做USACO时碰到的。
题目:
Broken Necklace
You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

                1 2                               1 2
            r b b r                           b r r b
          r           b                       b         b
         r              r                     b           r
        r                r                   w             r
       b                 r                 w               w
      b                   b               r                 r
      b                   b               b                 b
      b                  b               r                 b
       r                r                 b               r
        b             r                   r             r
         b           r                     r           r
           r       r                         r       b
             r b r                             r r w
            Figure A                         Figure B
                        r red bead
                        b blue bead
                        w white bead

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.

Example
For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration will include the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

PROGRAM NAME: beads
INPUT FORMAT
Line 1:  N, the number of beads
Line 2:  a string of N characters, each of which is r, b, or w

SAMPLE INPUT (file beads.in)
29
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT
A single line containing the maximum of number of beads that can be collected from the supplied necklace.
SAMPLE OUTPUT (file beads.out)
11

OUTPUT EXPLANATION
Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb wwwbbrwrbrbrrbrbrwrwwrbwrwrrb
                       ****** *****
=====================
网上有很多版本的解法。我找到一个。却在第三次测试数据上通不过

测试信息如下:
> Run 3: Execution error: Your program did not produce an answer
        that was judged as correct. The program stopped at 0.022 seconds;
        it used 1900 KB of memory.

        Here are the respective outputs:
        ----- our output ---------
        74
        ---- your output ---------
        72
        --------------------------

        ------ Data for Run 3 ------
        77
        rwrwrwrwrwrwrwrwrwrwrwrwbwrwbwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwrwr
        ----------------------------

    Test 3: BADCHECK 0.022 (0.022 secs, 1900 KB)

错误程序代码在下面,你能找出错误在哪里么?不许用OD哦~~~
#include <stdio.h>
#include <string.h>
int main ()
{
int n,i;
int j,k,left,right;
int b[400];
int max=0,max1=0;
char a[400];
FILE *fin=fopen("beads.in","r"),*fout=fopen("beads.out","w");;

fscanf(fin,"%d\n%s",&n,a);
for(j=0;j<n;j++)
{
  for(i=0;i<n;i++)
  {
   left=0;right=1;
   while(i-left>=0&&(a[i-left]==a[i]||a[i-left]=='w')) left++;
   while(i+right<n&&(a[i+right]==a[i+1]||a[i+right]=='w')) right++;
   b[i]=left+right-1;
   if(max<b[i]) max=b[i];
  }
  for(k=n;k>0;k--) a[k]=a[k-1];
  a[0]=a[n];
  if(max1<max) max1=max;
}
fprintf(fout,"%d\n",max1);
fclose(fin);
fclose(fout);
exit(0);
}

先看程序思路可能会被他先入为主的带过去,建议先自己写出来。
话说我是用OD调了下才知道错误在哪里的。
再次强烈建议老鸟绕道。

[培训]内核驱动高级班,冲击BAT一流互联网大厂工作,每周日13:00-18:00直播授课

收藏
点赞0
打赏
分享
最新回复 (0)
游客
登录 | 注册 方可回帖
返回